Intermittent slowness and login delays

Incident Report for IG

Resolved

This incident has been resolved.
Posted Sep 10, 2026 - 12:22 UTC

Update

We are continuing to investigate this issue.
Posted Sep 10, 2026 - 12:21 UTC

Update

All systems are operational now.
Posted Sep 10, 2026 - 12:16 UTC

Update

We are continuing to investigate this issue.
Posted Sep 10, 2026 - 12:14 UTC

Investigating

We are aware that some clients are experiencing intermittent slowness and delays when logging in to IG.com. Our teams are investigating.

In the meantime, use our mobile application, please.

We will provide a further update once the situation changes. We apologise for the inconvenience.
Posted Sep 10, 2026 - 12:09 UTC
This incident affected: Web platform.